[BioC] GEOquery problem

Ding, Wei wei.ding at spcorp.com
Fri Mar 19 15:35:38 CET 2010


I am trying to use getGEO function to get GEO data. It worked like charm
before, howevre I can't get it working recently. The errors are not
consistant. Sometimes I got error like  
> gse10240 <- getGEO("GSE2034", GSEMatrix=T)
Error in curlPerform(curl = curl, .opts = opts, .encoding = .encoding) :

  Access denied: 421

Even after Sean mentioned it's solved

Most times I got the following error. It seems that I could download the
the data, even with some warning message. However I couldn't open the
> gse10240 <- getGEO("GSE10240", GSEMatrix=T)
Found 1 file(s)
trying URL
using Synchronous WinInet calls
opened URL
downloaded 1.1 Mb

trying URL
Content type 'geo/text' length 200 bytes opened URL downloaded 27.5 Mb

File stored at: 
Warning message:
In download.file(myurl, destfile, mode = mode) :
  downloaded length 28885636 != reported length 200
> names(gse10240)
[1] "GSE10240_series_matrix.txt.gz"
> names(gse10240)
[1] "GSE10240_series_matrix.txt.gz"

> lapply(GSMList(gse10240), function(x) {Meta(x)$platform})
Error in function (classes, fdef, mtable)  : 
  unable to find an inherited method for function "GSMList", for
signature "list"

Any idea?


Wei Ding, PhD
Principal Scientist
Molecular Design and Informatics
T: 908 740 2592
F: 908 740 4496
wei.ding at spcorp.com

Merck Research Laboratories
2015 Galloping Hill Road
Kenilworth, NJ 07033 USA

This message and any attachments are solely for the
intended recipient. If you are not the intended recipient,
disclosure, copying, use or distribution of the information 
included in this message is prohibited -- Please 
immediately and permanently delete.

More information about the Bioconductor mailing list