[BioC] problems when trying to use biomaRt

Jenny Drnevich drnevich at illinois.edu
Wed Mar 17 14:39:42 CET 2010

Hi Juan,

This won't be much help, other to say that I have the exact same 
problem on my machine, and I've never been able to figure out exactly 
what the problem is. I think it has something to do with our system's 
firewall or something, because once this happens, I can't even get 
biomart.org up on a browser!! It's like they are blocking the 
connection or something. Here's the start of the thread from before: 
I confess I haven't spent much time since then trying to resolve the 
problem because I haven't really needed to use biomaRt. It is very 
inconvenient, and I'd like to figure it out at some point...

Good luck,

 > sessionInfo()
R version 2.10.1 (2009-12-14)

[1] LC_COLLATE=English_United States.1252
[2] LC_CTYPE=English_United States.1252
[3] LC_MONETARY=English_United States.1252
[5] LC_TIME=English_United States.1252

attached base packages:
[1] grid      stats     graphics  grDevices datasets  utils     methods
[8] base

other attached packages:
  [1] biomaRt_2.2.0        limma_3.2.1          affyQCReport_1.24.0
  [4] lattice_0.17-26      xtable_1.5-6         simpleaffy_2.22.0
  [7] genefilter_1.28.2    made4_1.20.0         scatterplot3d_0.3-29
[10] gplots_2.7.4         caTools_1.10         bitops_1.0-4.1
[13] gdata_2.6.1          gtools_2.6.1         RColorBrewer_1.0-2
[16] ade4_1.4-14          affyPLM_1.22.0       preprocessCore_1.8.0
[19] gcrma_2.18.1         affycoretools_1.18.0 KEGG.db_2.3.5
[22] GO.db_2.3.5          RSQLite_0.8-0        DBI_0.2-5
[25] AnnotationDbi_1.8.1  affy_1.24.2          Biobase_2.6.1
[28] RWinEdt_1.8-2

loaded via a namespace (and not attached):
affyio_1.14.0      annaffy_1.18.0     annotate_1.24.0    Biostrings_2.14.10
Category_2.12.0    GOstats_2.12.0     graph_1.24.1       GSEABase_1.8.0
IRanges_1.4.9      RBGL_1.22.0        RCurl_1.2-1        splines_2.10.1
[13] survival_2.35-7    tools_2.10.1       XML_2.6-0

At 06:00 AM 3/17/2010, Juan Pablo Fededa wrote:
>Dear bioconductor-help contributors,
>I'm trying to use biomaRt package in R, and when I run the next line, the R
>GUI crashes:
>ensembl = useMart("ensembl", dataset = "hsapiens_gene_ensembl")
>Theres is no error message at all, simply R is not responding anymore.
>when loading library(biomaRt) the prompt sign appears again, and you can
>already run basic things like:
>When I run sessionInfo() I get this:
>R version 2.10.1 (2009-12-14)
>[1] LC_COLLATE=English_United States.1252  LC_CTYPE=English_United
>[3] LC_MONETARY=English_United States.1252
>[5] LC_TIME=English_United States.1252
>attached base packages:
>[1] stats     graphics  grDevices utils     datasets  methods   base
>other attached packages:
>[1] biomaRt_2.2.0
>loaded via a namespace (and not attached):
>[1] RCurl_1.3-1 XML_2.6-0
>Do you have any idea of what can I change to make it work?
>Thanks in advance,
>         [[alternative HTML version deleted]]
>Bioconductor mailing list
>Bioconductor at stat.math.ethz.ch
>Search the archives: 

Jenny Drnevich, Ph.D.

Functional Genomics Bioinformatics Specialist
W.M. Keck Center for Comparative and Functional Genomics
Roy J. Carver Biotechnology Center
University of Illinois, Urbana-Champaign

330 ERML
1201 W. Gregory Dr.
Urbana, IL 61801

ph: 217-244-7355
fax: 217-265-5066
e-mail: drnevich at illinois.edu

More information about the Bioconductor mailing list