[Bioc-devel] error on riesling1 but not on palomino3

Jennifer Wokaty Jenn||er@Wok@ty @end|ng |rom @ph@cuny@edu
Fri Mar 4 21:27:57 CET 2022

Hi Oleksii,

Although it's marked as failing on the devel package page when viewing the short report, if you click on the long report (top right), it's only because of the errors on Riesling. I can confirm that that the issues on Riesling are not a problem for the next Bioconductor release as we will only be looking for errors on Palomino3 (as well as Nebbiolo1 and Merida1). This machine has the new R tool chain for R that we must use going forward for the Windows builds. ?

Jennifer Wokaty
Bioconductor Core Team
From: Oleksii Nikolaienko <oleksii.nikolaienko using gmail.com>
Sent: Thursday, February 24, 2022 5:05 AM
To: Jennifer Wokaty
Cc: bioc-devel using r-project.org
Subject: Re: [Bioc-devel] error on riesling1 but not on palomino3

Thanks Jennifer,
I tried to fix it and now ran into another (known?) issue because of lack of proper support for "snprintf". I would like to disregard this error, but could you please confirm that it won't be a problem for a coming Bioc release? Package is marked as failing its build on the dev package page...


On Wed, 23 Feb 2022 at 15:14, Jennifer Wokaty <Jennifer.Wokaty using sph.cuny.edu<mailto:Jennifer.Wokaty using sph.cuny.edu>> wrote:
Hi Oleksii,

Palomino3, which has the new UCRT toolchain to allow native support of UTF-8 and non-European languages, will replace Riesling1 soon, so please disregard the error on Riesling1, which is only running for historical reference.

We're also working on a way to help troubleshoot issues related to Windows environments.

Jennifer Wokaty
Bioconductor Core Team

From: Bioc-devel <bioc-devel-bounces using r-project.org<mailto:bioc-devel-bounces using r-project.org>> on behalf of Oleksii Nikolaienko <oleksii.nikolaienko using gmail.com<mailto:oleksii.nikolaienko using gmail.com>>
Sent: Wednesday, February 23, 2022 4:44 AM
To: bioc-devel using r-project.org<mailto:bioc-devel using r-project.org>
Subject: [Bioc-devel] error on riesling1 but not on palomino3

***ATTENTION: This email came from an external source. Do not open attachments or click on links from unknown senders or unexpected emails.***

Dear Bioc team,
my package (epiallleleR) currently fails tests on riesling1, but not on the
other hosts. Wrong results are produced by compiled c++ code, and at the
moment I don't understand why. I can see that both Windows hosts use GCC
8.3.0, but the compiler flags are different. I don't have access to
Windows, but I wasn't able to reproduce this error on my Linux with GCC
7.5.0 when tried to set "-fno-reorder-blocks-and-partition" in my Makevars,
or did "pkgbuild::with_debug(devtools::check())".
What are the other differences between riesling1 and palomino3? Is, for
example, sizeof(int)<4? And what can I do to debug it if I don't have
Windows around?

Best regards,

        [[alternative HTML version deleted]]

Bioc-devel using r-project.org<mailto:Bioc-devel using r-project.org> mailing list

	[[alternative HTML version deleted]]

More information about the Bioc-devel mailing list