[Bioc-devel] Removal of large items in git history - BiocCheck warning

stefano m@ng|o|@@te|@no @end|ng |rom gm@||@com
Mon Mar 8 23:18:05 CET 2021


you can use  bfg-repo-cleaner  ,

have a read to this document, in the section "eliminate big files from repo"


Best wishes.

*Stefano *

Stefano Mangiola | Postdoctoral fellow

Papenfuss Laboratory

The Walter Eliza Hall Institute of Medical Research

+61 (0)466452544

Il giorno mar 9 mar 2021 alle ore 09:11 Nitesh Turaga <
nturaga.bioc using gmail.com> ha scritto:

> Hi Alan,
> Did you manage to solve this?
> There seems to be objects in your git repo which are bigger than the size
> which is required by Bioconductor for a software package. Please check
> hidden files as well.
> One test you can do is, to clone your package from github and see how much
> MB are downloaded to this new location. This is a good test to check which
> files are still larger than the limit.
> Best,
> Nitesh
> On 3/4/21, 11:19 AM, "Bioc-devel on behalf of Murphy, Alan E" <
> bioc-devel-bounces using r-project.org on behalf of a.murphy using imperial.ac.uk>
> wrote:
>     Hi all,
>     I am working on the development of EWCE<
> https://github.com/NathanSkene/EWCE> for submission to Bioconductor. I
> have removed some large objects from the package and moved them to a
> separate ExperimentHub package however, after their removal, I got a
> BiocCheck large file warning.
>     To deal with the data stored in git history, I followed the
> instructions to use the BFG cleaner with the max size set to 5MB. This
> appeared to work and some things were removed but yet I still get the
> warning below:
>     $warning[1] "The following files are over 5MB in size:
> '.git/objects/pack/pack-366a7ab7a2ba4e656f3a9f3f1408be7ab9f41303.pack'"
>     If I try to rerun the BFG cleaner I get the following output:
>     Warning : no large blobs matching criteria found in packfiles - does
> the repo need to be packed?
>     I have tried two different methods to using the BFG cleaner, one from
> BFG<https://rtyley.github.io/bfg-repo-cleaner/> themselves and one from
> Bioconductor<
> https://bioconductor.org/developers/how-to/git/remove-large-data/>. I
> have also completed all steps in both including the prune step:
>     git reflog expire --expire=now --all && git gc --prune=now --aggressive
>     I have even tried reducing the max from 5MB to 1MB but still nothing
> seems to be left eve at that size. Does anyone know of another way to sort
> this issue or have any clue what I may be doing wrong?
>     Kind regards,
>     Alan.
>     Alan Murphy
>     Bioinformatician
>     Neurogenomics lab
>     UK Dementia Research Institute
>     Imperial College London
>         [[alternative HTML version deleted]]
>     _______________________________________________
>     Bioc-devel using r-project.org mailing list
>     https://stat.ethz.ch/mailman/listinfo/bioc-devel
> _______________________________________________
> Bioc-devel using r-project.org mailing list
> https://stat.ethz.ch/mailman/listinfo/bioc-devel

	[[alternative HTML version deleted]]

More information about the Bioc-devel mailing list