[Bioc-devel] Build error "failure: length > 1 in coercion to logical" not reproducible

bode@hoier m@iii@g oii bioi@i@jku@@t bode@hoier m@iii@g oii bioi@i@jku@@t
Thu Jun 17 11:32:00 CEST 2021

Dear colleagues,

It seems to me that, starting with the latest BioC devel branch (3.14), the
build systems have become more pedantic about logical vectors of length > 1
in conditions. Two of the packages I am maintaining, 'kebabs' and 'procoil'
currently fail to build. Surely I want to fix this. However, I cannot
reproduce these errors on my local system (R 4.1.0 alpha on Ubuntu 18.04
LTS). The discussions https://support.bioconductor.org/p/9137605/ and
https://github.com/Bioconductor/BBS/issues/71  have pointed me to the
setting "_R_CHECK_LENGTH_1_CONDITION_=verbose". 

First question: Can anybody confirm that this has been changed in the recent

Second question: I have tried to include
"_R_CHECK_LENGTH_1_CONDITION_=verbose" in my .Renviron file and it seems
that my R session respects that. However, when I run 'R CMD build' on the
aforementioned packages, they still build fine. The suggestions in
https://github.com/Bioconductor/BBS/issues/71 don't work for me either
(maybe I have done something wrong). I would actually like to reproduce the
errors in my local system, since this will help me fixing the errors and
testing the changes. So can anybody give me advice how I can make my local
installation to check for logical vectors of length > 1 in conditions more

Thanks a lot in advance,

More information about the Bioc-devel mailing list