[Bioc-devel] Getting ready for package submission, running into a couple of errors/warnings that I can't figure out

Wight, Andrew E. AndrewE_W|ght @end|ng |rom DFCI@HARVARD@EDU
Mon Jul 12 23:58:10 CEST 2021

Good evening all - I'm getting my first package ready for submission to Bioconductor, and I'm running into a couple of errors/warnings when I run R CMD CHECK or BiocCheck. All of my current troubleshooting on these errors has come up blank, so I'm hoping someone here can point me in the right direction.

I'm running R4.1 on Ubuntu 20.04, Bioconductor 3.13, and BiocCheck 1.28

  1.  R CMD check warning: �qpdf� is needed for checks on size reduction of PDFs

I am getting this warning with R CMD check despite the fact that I have installed qpdf and it is visible to my R session. Stack Exchange suggested a couple of fixes in .Renviron, none of which helped. This seems like a new problem in R4.x, and possibly is only a problem with packages intended for CRAN, but I wanted to make sure it wouldn't cause headaches during review.

  1.  BiocCheck error: Maintainer must register at the support site; visit https://support.bioconductor.org/accounts/signup/

I am registered on the support site as AndrewE_Wight using dfci.harvard.edu, which is the same email address as listed in my package's DESCRIPTION, so I'm not sure what else to do here. I've been registered on the support site for 7 months now and have a verified email address.

  1.  BiocCheckGitClone error: System Files found that should not be git tracked:

I accidentally tracked these two files ages past, but have long since added them to .gitignore and deleted them with git rm --cached <filename>. I can confirm that they are gone with git ls-files and git ls-files --cache; they appear in neither of these lists when I run the command. To be certain, I made a fresh clone of the repo on a new computer and ran BiocCheckGitClone, but still got this error despite neither of these files showing up anywhere in the git as far as I can tell.

My apologies for what seem like basic problems - these look like they should be straightforward fixes (install qpdf, register for the site, and remove the offending files), but none of those fixes worked and I'm not sure where to go from here. Any insight anyone can give on how to fix these errors is greatly appreciated!



The information in this e-mail is intended only for the ...{{dropped:15}}

More information about the Bioc-devel mailing list