[Bioc-devel] EWCE Bioconductor package

Nitesh Turaga ntur@g@@b|oc @end|ng |rom gm@||@com
Thu Feb 11 17:57:08 CET 2021

I can help with git push access as needed once your package is resubmitted, if there are any issues with access rights.



On 2/11/21, 10:01 AM, "Bioc-devel on behalf of Vincent Carey" <bioc-devel-bounces using r-project.org on behalf of stvjc using channing.harvard.edu> wrote:

    Please disregard my note.  As Lori has indicated formal review must proceed
    before reinclusion.

    On Thu, Feb 11, 2021 at 9:51 AM Vincent Carey <stvjc using channing.harvard.edu>

    > EWCE may need to be reviewed for reinclusion.  I tried to check on R-devel
    > with the repo you mentioned.  Do you
    > have a current personal repo that passes check with Bioc 3.13/R-devel?
    > Quitting from lines 220-223 (EWCE.Rmd)
    > Error: processing vignette 'EWCE.Rmd' failed with diagnostics:
    > Invalid attribute(s): percentage_gc_content
    > Please use the function 'listAttributes' to get valid attribute names
    > --- failed re-building ‘EWCE.Rmd’
    > On Thu, Feb 11, 2021 at 9:41 AM Murphy, Alan E <a.murphy using imperial.ac.uk>
    > wrote:
    >> Hi all,
    >> My apologies in advance if this is not the correct mailing list for this
    >> question, regarding development to the EWCE Bioconductor package.
    >> I work as part of Dr. Nathan Skene's group who submitted the package EWCE<
    >> https://bioconductor.riken.jp/packages/3.5/bioc/html/EWCE.html#since> to
    >> Bioconductor some years ago. The package fell out of maintenance and as
    >> such was deprecated from Bioconductor 3.6. We are working to update and
    >> hopefully, reinstate the package but are running into issues when pushing
    >> any changes to Bioconductor. We have been following instructions here<
    >> http://bioconductor.org/developers/how-to/git/sync-existing-repositories/>
    >> to try and sync our Github updates with the Bioconductor version but can't
    >> seem to push the new, merged version to Bioconductor.
    >> To test the cause of the issue, we cloned the repo:
    >> git clone https://git.bioconductor.org/packages/EWCE
    >> And updated the version of the package in the DESCRIPTION file and tried
    >> pushing the change, using Nathan's account which is associated with the
    >> package. However, we still can't push to Bioconductor, getting the error:
    >> -bash-4.2$ git push origin master
    >> FATAL: W any packages/EWCE n.skene DENIED by fallthru
    >> (or you mis-spelled the reponame)
    >> fatal: Could not read from remote repository.Please make sure you have
    >> the correct access rights
    >> and the repository exists.
    >> It appears it does recognise Nathan's account but doesn't think he has
    >> access rights to the repo. It is worth noting that EWCE is also not listed
    >> on his account's webpage.
    >> We are wondering if this issue is caused by EWCE being deprecated and if
    >> so, what are the necessary steps to reinstate it?
    >> Kind regards,
    >> Alan.
    >> Alan Murphy
    >> Bioinformatician
    >> Neurogenomics lab
    >> UK Dementia Research Institute
    >> Imperial College London
    >>         [[alternative HTML version deleted]]
    >> _______________________________________________
    >> Bioc-devel using r-project.org mailing list
    >> https://stat.ethz.ch/mailman/listinfo/bioc-devel

    The information in this e-mail is intended only for the ...{{dropped:18}}

    Bioc-devel using r-project.org mailing list

More information about the Bioc-devel mailing list