[Bioc-devel] GEOquery run into problem with Sys.setenv("VROOM_CONNECTION_SIZE")

array chip @rr@ypro|||e @end|ng |rom y@hoo@com
Wed Dec 1 21:05:52 CET 2021

Hi, I a using GEOquery to download some microarray datasets. It worked previously without any problem under old R version (3.5 probably), but now run into problem now I've updated R to version 4.0.5.


# Found 1 file(s)
# GSE137140_series_matrix.txt.gz
# trying URL 'https://ftp.ncbi.nlm.nih.gov/geo/series/GSE137nnn/GSE137140/matrix/GSE137140_series_matrix.txt.gz'
# Content type 'application/x-gzip' length 45700106 bytes (43.6 MB)
# downloaded 43.6 MB

# Error: The size of the connection biffer (131072) was not large enough
# to fit a complete line:
#    Increase it by setting 'Sys.setenv("VROOM_CONNECTION_SIZE")'

sessionInfo( )

R version 4.0.5 (2021-03-31)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows 10 x64 (build 19042)

Matrix products: default

[1] LC_COLLATE=English_United States.1252  LC_CTYPE=English_United States.1252    LC_MONETARY=English_United States.1252
[4] LC_NUMERIC=C                           LC_TIME=English_United States.1252    

attached base packages:
[1] parallel  stats     graphics  grDevices utils     datasets  methods   base     

other attached packages:
[1] limma_3.46.0        GEOquery_2.58.0     Biobase_2.50.0      BiocGenerics_0.36.1 BiocManager_1.30.12

loaded via a namespace (and not attached):
[1] xml2_1.3.3       magrittr_2.0.1   hms_1.1.1        bit_4.0.4        tidyselect_1.1.1 R6_2.5.1         rlang_0.4.12     fansi_0.5.0     
[9] dplyr_1.0.7      tools_4.0.5      vroom_1.5.7      utf8_1.2.2       DBI_1.1.1        withr_2.4.3      ellipsis_0.3.2   bit64_4.0.5     
[17] assertthat_0.2.1 tibble_3.1.6     lifecycle_1.0.1  crayon_1.4.2     tidyr_1.1.4      purrr_0.3.4      readr_2.1.1      tzdb_0.2.0      
[25] vctrs_0.3.8      curl_4.3.2       glue_1.5.1       compiler_4.0.5   pillar_1.6.4     generics_0.1.1   pkgconfig_2.0.3

I tried to increase the connection buffer by Sys.setenv("VROOM_CONNECTION_SIZE"=131072*5), but no success.

Can someone tell me what's going on? Why it worked flawlessly, but now the problem with new R and new bioconductor versions?



More information about the Bioc-devel mailing list