[Bioc-devel] Build issues under macOS

McDavid, Andrew Andrew_Mcd@v|d @end|ng |rom URMC@Roche@ter@edu
Wed Sep 9 17:26:42 CEST 2020

FWIW I am getting the same error in my builds on merida1 for a package that is under review:

Similar to Matt, I have Rcpp code, but no fortran code so I am perplexed why there is any linking to gfortran happening in the first place, what install_name_tool is trying to do to the .so, and how I could attempt to reproduce this issue locally to investigate it myself.

Andrew McDavid
Biostatistics and Computational Biology
Office: SRB 4.206 Ph: 585.275.5983

On Sep 9, 2020, at 6:00 AM, bioc-devel-request using r-project.org<mailto:bioc-devel-request using r-project.org> wrote:

Date: Wed, 9 Sep 2020 01:03:10 +0000
From: "Stone, Matt" <mstone using fredhutch.org<mailto:mstone using fredhutch.org>>
To: "bioc-devel using r-project.org<mailto:bioc-devel using r-project.org>" <bioc-devel using r-project.org<mailto:bioc-devel using r-project.org>>
Subject: [Bioc-devel] Build issues under macOS
Message-ID: <294FBFF9-0972-4F77-8B8C-1B8E5A7F5156 using fredhutch.org<mailto:294FBFF9-0972-4F77-8B8C-1B8E5A7F5156 using fredhutch.org>>
Content-Type: text/plain; charset="utf-8"


I've begun the submission of a new package [1], but I'm encountering some errors in the automated build under macOS on merida1 and would greatly appreciate any assistance.

I've currently tried to build twice, once upon initial submission and once after updating the DESCRIPTION to remove a redundant Maintainer field. I'm a bit confused that each build failed with different errors, as the only difference between the two was the removal of the Maintainer field.

In the first build [2], the binary build failed because the installer could not link to the fortran libraries. I have previously encountered a similar issue on my own macbook and was able to work around it by installing gfortran directly [3] rather than through homebrew. I have this noted in the package's README, but is there a better solution to ensure compatibility in more environments, including merida1?

In the second build [4], the check failed because the package was uninstallable, and the binary build failed because edgeR could not be found. I'm assuming the latter is the cause of the former error. edgeR is an indirect dependency via scran; is it necessary to make it an explicit import?

Before submission, I set up the BiocCheck github action supported by r-lib [5], and was able to build the package and run a mostly clean (minus a few NOTEs) check/BiocCheck under Ubuntu, Windows, and macOS. Is anyone familiar with the distinction between the environments on merida1 and the docker image in this workflow? I'd be happy to help update the latter to be consistent with merida1.

Thank you!


	[[alternative HTML version deleted]]

More information about the Bioc-devel mailing list