[Bioc-devel] netDx: Build errors despite code working in BioC docker

Shraddha Pai @hr@ddh@p@|@neuro @end|ng |rom gm@||@com
Thu Jun 11 23:44:00 CEST 2020

Hello BioC community,
I have been trying unsuccessfully for a week now to update both release and
dev branches of the netDx packages but am still getting build errors.

Today I got a build error for the release branch:

I tried to reproduce the error in the following way:
1. I have a BioC docker that runs R 4.0.0 and Biobase 2.48.0 (from
2. I ran a fresh "git clone" to get the latest netDx. "git clone
https://git.bioconductor.org/packages/netDx" , after the URL on the build
page above.
3. Switched to release branch "git checkout RELEASE_3_11"
4. Reinstalled netDx "R CMD INSTALL netDx" and confirmed using
sessionInfo(); netDx_1.0.1
5. Set up Renvirons as mentioned on the build page and launched R also as
suggested there, after declaring the corresponding variable.
6. The offending vignette is "Predict_CaseControl_from_CNV.Rmd". So I first
ran "knitr::purl("Predict_CaseControl_from_CNV.Rmd") , and then removed the
suppressMessages() around the offending function call,
7. Ran "source("Predict_CaseControl_from_CNV.R"). And it ran through

What am I missing? Is it that the snapshot date it from June 10  but the
build page is from June 11 so I need to wait for the changes to kick in?

I'm also getting errors with the devel branch, so will probably separately
write about that (sigh).


Shraddha Pai, PhD
http://shraddhapai.com ; @spaiglass on Twitter
Post-doctoral Fellow, http://baderlab.org
The Donnelly Centre for Cellular and Biomolecular Research
University of Toronto

	[[alternative HTML version deleted]]

More information about the Bioc-devel mailing list