[Bioc-devel] Build failing for package 'fcoex' and I do not know why

Martin Morgan mtmorg@n@b|oc @end|ng |rom gm@||@com
Thu Dec 24 21:34:29 CET 2020

Actually, I generate other errors, but not the build report errors.

I see your package git repository includes 'cached' files, vignettes/fcoex_files; these are not appropriate for a git repository, since they reflect some state on your particular machine, rather than on the build system or user machines in general.

Here's what I did:

  BiocManager::version()  # 3.13, the current release
  BiocManager::valid()    # TRUE, all packages are up-to-date
  BiocManager::install("fcoex")  # a short-cut to install dependencies

Then I tried to build your package, making sure I had no weird files or uncomitted changes

  cd /tmp
  git clone --depth 1 git using git.bioconductor.org:packages/fcoex
  R CMD build fcoex

The output was

* checking for file 'fcoex/DESCRIPTION' ... OK
* preparing 'fcoex':
* checking DESCRIPTION meta-information ... OK
* installing the package to build vignettes
* creating vignettes ... ERROR
--- re-building ‘fcoex.Rmd’ using rmarkdown

Attaching package: 'MatrixGenerics'

The following objects are masked from 'package:matrixStats':

    colAlls, colAnyNAs, colAnys, colAvgsPerRowSet, colCollapse,
    colCounts, colCummaxs, colCummins, colCumprods, colCumsums,
    colDiffs, colIQRDiffs, colIQRs, colLogSumExps, colMadDiffs,
    colMads, colMaxs, colMeans2, colMedians, colMins, colOrderStats,
    colProds, colQuantiles, colRanges, colRanks, colSdDiffs, colSds,
    colSums2, colTabulates, colVarDiffs, colVars, colWeightedMads,
    colWeightedMeans, colWeightedMedians, colWeightedSds,
    colWeightedVars, rowAlls, rowAnyNAs, rowAnys, rowAvgsPerColSet,
    rowCollapse, rowCounts, rowCummaxs, rowCummins, rowCumprods,
    rowCumsums, rowDiffs, rowIQRDiffs, rowIQRs, rowLogSumExps,
    rowMadDiffs, rowMads, rowMaxs, rowMeans2, rowMedians, rowMins,
    rowOrderStats, rowProds, rowQuantiles, rowRanges, rowRanks,
    rowSdDiffs, rowSds, rowSums2, rowTabulates, rowVarDiffs, rowVars,
    rowWeightedMads, rowWeightedMeans, rowWeightedMedians,
    rowWeightedSds, rowWeightedVars

Attaching package: 'BiocGenerics'

The following objects are masked from 'package:parallel':

    clusterApply, clusterApplyLB, clusterCall, clusterEvalQ,
    clusterExport, clusterMap, parApply, parCapply, parLapply,
    parLapplyLB, parRapply, parSapply, parSapplyLB

The following objects are masked from 'package:stats':

    IQR, mad, sd, var, xtabs

The following objects are masked from 'package:base':

    Filter, Find, Map, Position, Reduce, anyDuplicated, append,
    as.data.frame, basename, cbind, colnames, dirname, do.call,
    duplicated, eval, evalq, get, grep, grepl, intersect, is.unsorted,
    lapply, mapply, match, mget, order, paste, pmax, pmax.int, pmin,
    pmin.int, rank, rbind, rownames, sapply, setdiff, sort, table,
    tapply, union, unique, unsplit, which.max, which.min

Attaching package: 'S4Vectors'

The following objects are masked from 'package:base':

    I, expand.grid, unname

Welcome to Bioconductor

    Vignettes contain introductory material; view with
    'browseVignettes()'. To cite Bioconductor, see
    'citation("Biobase")', and for packages 'citation("pkgname")'.

Attaching package: 'Biobase'

The following object is masked from 'package:MatrixGenerics':


The following objects are masked from 'package:matrixStats':

    anyMissing, rowMedians

Created new fcoex object.
Getting SU scores
Running FCBF to find module headers
Calculating adjacency matrix
Trimming and getting modules from adjacency matrix
Warning in file(con, "rb") :
  file("") only supports open = "w+" and open = "w+b": using the former
Warning in readChar(file, nchars = nChars, useBytes = TRUE) :
  text connection used with readChar(), results may be incorrect
Quitting from lines 117-122 (fcoex.Rmd)
Error: processing vignette 'fcoex.Rmd' failed with diagnostics:
invalid 'nchars' argument
--- failed re-building ‘fcoex.Rmd’

SUMMARY: processing the following file failed:

Error: Vignette re-building failed.
Execution halted

I know that this is a different error from on the build system, but it points to some problems. What do you see? Have you tried to reproduce the problem reported on the build system using the docker image described at http://bioconductor.org/help/docker/ ?


On 12/24/20, 2:58 PM, "Bioc-devel on behalf of Tiago Lubiana" <bioc-devel-bounces using r-project.org on behalf of tiago.lubiana.alves using usp.br> wrote:

    Hello all,

    One package that I manage is failing both Devel and Release:


    A part code generates some plots and then saves them to a folder. This is
    failing in all machines, but I cannot reproduce the error on my computer
    (Ubuntu 18.04).

      save_plots(fc, name = "Example")

    Saving available plots.
    Error in `$<-.data.frame`(`*tmp*`, "point.size", value = numeric(0)) :
      replacement has 0 rows, data has 10
    Calls: save_plots ... makeContent.labelrepeltree -> $<- -> $<-.data.frame
    Execution halted

    Does anyone know what might be happening?

    Thank you very much and have happy (and safe) celebrations :)


    *Tiago Lubiana *
    *PhD Candidate in Bioinformatics, University of São Paulo*
    *Computational Systems Biology Laboratory (CSBL)*

    	[[alternative HTML version deleted]]

    Bioc-devel using r-project.org mailing list

More information about the Bioc-devel mailing list