[Bioc-devel] regionReport error leads to ggbio & biovizBase issues, confusingly not on all OS though

Leonardo Collado Torres |co||@dotor @end|ng |rom gm@||@com
Thu Apr 9 16:10:47 CEST 2020

Hi BioC-devel,

I was able to trace a regionReport error back to ggbio & biovizBase.
However, I'm completely clueless as to why (a) it only appears in some
OS (though this has changed over time) and (b) it does not seem to be
a problem with derfinderPlot on the build reports for the same OS.

## Short version

data(hg19IdeogramCyto, package = 'biovizBase')
p.ideo <- plotIdeogram(hg19IdeogramCyto, 'chr21')

This code on linux leads to 3 warnings from plotIdeogram() and an
error from tracks(). Also, validObject(hg19IdeogramCyto) fails (this
also fails on macOS).

One warning (about seqlengths) and validObject() can be fixed with:

hg19IdeogramCytoFixed <- updateObject(hg19IdeogramCyto)
    seqlengths(hg19IdeogramCytoFixed) <-
seqlengths(getChromInfoFromUCSC('hg19', as.Seqinfo =

This code is currently run from derfinderPlot::plotCluster() and for
some reason, the examples don't fail.

## Long version

My package regionReport has been failing for a while with the same
error on Bioc-release (3.10) and bioc-devel (3.11). I've been watching
the fails for a while and it's mostly:

* linux on 3.10, occasionally Windows
* linux on 3.11

Right now, it's only linux on both 3.10 and 3.11.

The error always is:

Quitting from lines 224-229 (basicExploration.Rmd)
Error in magick_image_trim(image, fuzz) :
  R: unable to get registry ID `cache:hosts' @
Calls: render ... <Anonymous> -> assert_image -> <Anonymous> ->

A while back, I reported that I couldn't reproduce this on 3.10 on
Windows (when it was failing). I've looked at the magick package and
it didn't seem to be the issue

After getting R 4.0.0 setup on my macOS, I also couldn't reproduce it.
So I finally looked at Nitesh's work on dockers at

 docker run \
     -e PASSWORD=bioc \
     -p 8787:8787 \

There I could reproduce the build problem from regionReport and got a
more detailed error message. Using an interactive session where I ran
the internal code piece by piece, I got to the biovizBase + ggbio

derfinderPlot::plotCluster(), which is also a package I made, runs the
exact same code and has not failed at all on both bioc-release (3.10)
and devel (3.11) all this time. I would have expected derfinderPlot to
fail also (in which case it would have provided a more informative
error than the one hidden by rmarkdown in regionReport's build
reports). If I run the example for derfinderPlot::plotCluster() on
linux it does fail, however this was not picked up by the BioC build
report. Hence why I'm even more confused.

Anyway, hopefully fixing the ggbio/biovizBase issue will fix
derfinderPlot::plotCluster() and in turn regionReport.

As to the inconsistencies across OS or between the BioC build report
output for derfinderPlot and what I see on linux, I have no idea

## Gist with details

I have a Gist with all the output logs and the R session information
at https://gist.github.com/lcolladotor/b7585962082263b377c02fa4451f27e6.
Here's the brief description for each file.

* macOS_regionReport_build.txt: runs R CMD build for regionReport
without a problem
* linux_regionReport_build.txt: fails to run R CMD build for
regionReport and provides more details and the BioC build report. This
is where we can start to see errors related to the ideograms. I
thought that fixing this would only involve a updateObject() call at
this point.
* reprex_ggbio_code.R: smallest code I have for reproducing this issue
* macOS_reprex_ggbio_output.txt: runs without errors (though it still
has warnings about seqlengths and other ggbio parts)
* linux_reprex_ggbio_output.txt: fails to run the small reprex
* reprex_derfinderPlot_code.R: runs the example for derfinderPlot::plotCluster()
* macOS_reprex_derfinderPlot_output.txt: similar story to
* linux_reprex_derfinderPlot_output.txt: the example fails here too!
Which makes me even more confused. I mean, it's consistent with
regionReport and the ggbio reprex. However, I then don't understand
why this hasn't failed in the BioC builds.


Leonardo Collado Torres, Ph. D., Research Scientist
Lieber Institute for Brain Development
855 N Wolfe St, Suite 300
Baltimore, MD 21205

On Tue, Mar 17, 2020 at 6:35 PM Leonardo Collado Torres
<lcolladotor using gmail.com> wrote:
> Hi BioC-devel,
> I spent some time yesterday getting my Windows laptop ready to debug a
> Windows OS-only issue in regionReport (bioc-release 3.10), but
> ultimately I couldn't reproduce it. Since the error seems to be some
> type of cache, I bumped the version number but it still failed today
> and it then also failed on bioc-devel (3.11) on Linux (as well as
> Windows).
> ## Bioc-release (3.10) Windows is the only that fails
> Quitting from lines 224-229 (basicExploration.Rmd)
> Error: processing vignette 'regionReport.Rmd' failed with diagnostics:
> R: unable to get registry ID `cache:hosts' @
> error/registry.c/GetImageRegistry/202
> --- failed re-building ‘regionReport.Rmd’
> similarly
> Quitting from lines 224-229 (basicExploration.Rmd)
> Error in magick_image_trim(image, fuzz) :
>   R: unable to get registry ID `cache:hosts' @
> error/registry.c/GetImageRegistry/202
> Calls: render ... <Anonymous> -> assert_image -> <Anonymous> ->
> magick_image_trim
> ## Bioc-devel (3.11) Linux and Windows fails
> http://bioconductor.org/checkResults/release/bioc-LATEST/regionReport/malbec1-buildsrc.html
> However, I see at
> http://bioconductor.org/checkResults/devel/bioc-LATEST/regionReport/malbec2-buildsrc.html
> that the error appeared today also on the Linux bioc-devel builder.
> ## Google
> Searching for the error message led me to
> https://github.com/phw/peek/issues/112 which talks about disk space
> running out for ImageMagick. Do you think that this is something that
> is affecting the builders too? Do you have any suggestions I could
> try?
> Best,
> Leo

More information about the Bioc-devel mailing list