[Bioc-devel] scanVCF: _DNAencode(): invalid DNAString input character: '1'

Erik Fasterius erik@f@@teriu@ @ending from outlook@com
Tue Jan 8 15:07:04 CET 2019

I recently started to get a weird error when building the vignette to my seqCAT package, related to a VCF file I use as example data. The error itself looks like this:

scanVcf: _DNAencode(): invalid DNAString input character: '1' (byte value 49) path: (...)/seqCAT/extdata/example.vcf.gz

I can also reproduce the error by a simple `VariantAnnotation::readVCF()` call. It has worked fine until the latest devel-updates of other Bioconductor packages, so I assumed it was some new change that caused the error, but I cannot find anything in the NEWS seemingly related to this. I also tried to troubleshoot by manually inspecting my file, and it seems that the ANN field is the culprit; I can read the VCF if I remove the entirety of the INFO column. I cannot, however, seem to locate the erroneous data itself.

Does anybody have any idea what causes this?

	[[alternative HTML version deleted]]

More information about the Bioc-devel mailing list