[Bioc-devel] class name collision in cache: igvR and Gviz
paul.thurmond.shannon at gmail.com
Fri May 4 19:52:12 CEST 2018
I just discovered a class name collision - AnnotationTrack, in Gviz and my new package igvR. wish to get wise counsel before proceeding with a fix. Here’s the error message:
Found more than one class "AnnotationTrack" in cache;
using the first, from namespace ‘igvR' Also defined by ‘Gviz’
AnnotationTrack is an abstract base class in my new package igvR. The concrete derived classes at present are
It would be easy for me to rename AnnotationTrack to “GenomeAnnotationTrack” or even “igvAnnotationTrack”, thereby avoiding the name clash.
Reasonable? Fix in both release and devel?
More information about the Bioc-devel