[Bioc-devel] Question about Wercker continuous integration

Kevin RUE kevinrue67 at gmail.com
Fri Mar 16 12:53:27 CET 2018

Dear all,

I'm usually a big Travis CI fan, but I'm having a go at Wercker, using the
bioconductor/devel_core2 docker (I have also tried the rocker 'parent' ones
without further success).
I am running into the following issue:

* creating vignettes ... ERROR
Error: processing vignette 'NewPackage-vignette.Rmd' failed with
package ‘backports’ was installed by an R version with different internals;
it needs to be reinstalled for use with this R version
Execution halted
Error: Command failed (1)
In addition: Warning message:
`cleanup` is deprecated
Execution halted
Check Failed, dumping logs
find: ‘./*.Rcheck’: No such file or directory
failed: Check Failed

I've tried adding a task that re-installs the `backports` package from
source (CRAN), but I still get the same error.

My wercker.yml looks like:
box: bioconductor/devel_core2
        - script:
            name: Install devtools
            code: R -e "install.packages('devtools')"
        - script:
            name: Install backports
            code: R -e "install.packages('backports')"
        - jimhester/r-dependencies
        - jimhester/r-check
        - jimhester/r-lint
        - jimhester/r-coverage

Any help/advice/experience with Wercker would be greatly appreciated!

Best wishes,

	[[alternative HTML version deleted]]

More information about the Bioc-devel mailing list