[Bioc-devel] FW: Package build error

Ioannis Vardaxis ioannis.vardaxis at ntnu.no
Fri Oct 27 16:43:03 CEST 2017


Thanks for the answer. Sorry for not including the link!

For the references part: I am using roxygen2 to create the Rd formats and
the \insertRef{link to bib reference file} should work for that. It looked

#' @references \insertRef{macpetcite}{MACPET}

However I followed your suggestion and used the \references{} macro from
writing R documentation files, then the reference looks like:

#' \references{
#' Consortium EP (2012) \emph{An integrated encyclopedia of DNA elements
in the human genome.}.
#'  Nature, 489(7414), pp. 57­74.
#' }

When I build the package I get get a warning for that: "unexpected section
header '\references¹², the reference is there however when I search for
the documentation in R, but this warning is new.

Moreover, for the C++11: I have my cpp script which is mainly written
using Rcpp so the headers are:

#include <Rcpp.h>
using namespace Rcpp;

I included the SystemRequirements: C++11 in the DESCRIPTION file. But when
I look into the script I get error symbols on the left side for example:
 For "std::ceil² I get the ³call to ceil is ambiguous² however I specify
std:: so the error should not be there right? (same error for std::log,
std::round, std::sqrt, std::exp)
Moreover: for ³INFINITY² I get ³used of undeclared identifier INFINITY²,
but INFINITY is in c++11, so this should not be there either.
Furthermore, for "std::isnan² I get ³no member named isnan in namespace
std²,  but it should be in c++11.

However when I go to http://en.cppreference.com/w/cpp/numeric/math/exp and
check the function there, it says that the header for the above mentioned
functions is <cmath>
So I wonder if I should include something else in the headers of the

#include <cmath> for example, although I did that and the errors are

The package builds and runs, but I¹m sure I  am gonna get errors again
when I submit it.

Ioannis Vardaxis

Stipendiat IMF

On 27/10/2017, 08:01, "Hervé Pagès" <hpages at fredhutch.org> wrote:

>Hi Ioannis,
>The links to the build results generated  during the submission
>process are permanent (or at least remain valid for several months),
>so it's easier to provide the link to the particular results:
>As a special bonus, we all get the color version ;-)
>R uses its own markup language for man pages, called the Rd format.
>\insertRef is not a valid tag in that format. See the "2 Writing R
>documentation files" section of the "Writing R Extensions" manual for
>more information:
>Note that "Writing R Extensions" is the primary documentation for R
>package developers.
>If your code is C++11 and you don't have a src/Makevars or src/Makefile
>file, then you need to add
>   SystemRequirements: C++11
>in the DESCRIPTION file. This will invoke the correct compiler. This
>is also explained in "Writing R Extensions" in a subsection dedicated
>to "Using C++11 code":
>Finally, pushing changes to GitHub will automatically start the next
>build/check only if you've properly set up the web hook and if you bump
>the version of your package, as explained on the Contributions page:
>Hope this helps,
>On 10/26/2017 06:44 PM, Ioannis Vardaxis wrote:
>> Hey,
>> Yesterday I submitted an R package to Bioconductor and today I got the
>>build results with some error end warnings. Please find the build
>>results attached.
>> The file is quite long and there are a lot of things there. However
>>when I run R-check and BiocCheck on my MAC I don't get any and the
>>package runs fine.
>> We don't need to go through all the notes in the file, just the first
>>two highlighted ones.
>> For the first one, I get a warning for : unknown macro \insertRef. I
>>have a citation file in the package and I can't see any other way to add
>>citation on some R functions. Can I change it to something else?
>> Furthermore, I have only one c++ script, where I use Rcpp package. The
>>header of the script is:
>> #include <Rcpp.h>
>> using namespace Rcpp;
>> I wanted to include functions like std::round, std::log etc, but I got
>>an error that round is not in std namespace (see highlight two). How can
>>I tell Rcpp to recognise that? Because round Is at std for c++11 I think.
>> However I don't specify any src/Makevars file, because I though that it
>>is not needed anymore.
>> Finally,
>> When I make all the changes and fix the errors locally on my mac, I
>>then commit and push to GitHub again. Will this automatically start the
>>next build check for bioconuctor or do I have to do anything else?
>> Best
>> --
>> Ioannis Vardaxis
>> Stipendiat IMF
>> _______________________________________________
>> Bioc-devel at r-project.org mailing list
>Hervé Pagès
>Program in Computational Biology
>Division of Public Health Sciences
>Fred Hutchinson Cancer Research Center
>1100 Fairview Ave. N, M1-B514
>P.O. Box 19024
>Seattle, WA 98109-1024
>E-mail: hpages at fredhutch.org
>Phone:  (206) 667-5791
>Fax:    (206) 667-1319

More information about the Bioc-devel mailing list