[Bioc-devel] Problem pushing new versions of xcms via git svn dcommit

McDavid, Andrew Andrew_Mcdavid at URMC.Rochester.edu
Tue Jan 3 17:49:37 CET 2017

Hi Steffen,

Option 2 worked for me recently with a repo that had previous git history.  I think you after you run

    git branch --track biocmaster bioc/master

You need to run

    git checkout biocmaster

Then you may run git svn dcommit, which should just be a null op at this point.  I will add that if your repo has previous git history (like yours) you absolutely must cherry pick onto the svn repo or great suffering will ensue.  This is because, I believe, the histories of the svn repo and git repo are different.  Rebasing or merging tries to replay from the first commit of your git repo


On Jan 3, 2017, at 6:00 AM, bioc-devel-request at r-project.org<mailto:bioc-devel-request at r-project.org> wrote:

Hi all,?and a happy new year!

I am experiencing a lot of frustration getting changes from github
pushed to BioC svn, and that includes some fixes for build issues
in packages depending on xcms. I have tried several options:

1) git svn checkout, git remote add, git merge and git svn dcommit.
2) git clone github repo, update_remotes.sh?and git svn rebase

both of which seem to fail due to the same reason,
which seems to be somewhere around

	[[alternative HTML version deleted]]

More information about the Bioc-devel mailing list