[Bioc-devel] package 'msa' not building on veracruz2, but on toluca2 and other Mac OS systems

Ulrich Bodenhofer bodenhofer at bioinf.jku.at
Fri Apr 7 17:26:15 CEST 2017


The devel version of our package 'msa' currently does not compile on 
veracruz2 (R 3.4.0 alpha under OS X 10.11.6 El Capitan), but it seems to 
work on toluca2 (R-devel on OS X 10.9.5 Mavericks). I also checked on my 
Mac at home (R 3.3.3 under macOS 10.12.3 Sierra using the very latest 
version of Xcode), and it also compiles without any problems.

The error stems from a conflicting definition of the math functions 
'log2' and 'log10' in the source code of the ClustalOmega library which 
is integrated into 'msa' (the same error appears for the inline 
definition of 'log10'):

    hhalign/util-C.h:53:14: error: 'log2' is missing exception 
specification 'throw()'
    inline float log2(float x)  {return (x<=0? 

Any ideas? 'log2' and 'log10' are defined in the standard math library. 
The definitions work well on Linux along with '#include <cmath>' , while 
Windows requires '#include <math.h>'. So far, '#include <cmath>' also 
worked on Mac OS, but it seems that now, on veracruz2, neither one nor 
the other works. Any thoughts? Is this something I should care about or 
is there something exotic about veracruz2 such that I can simply ignore 
this issue?

Thanks a lot in advance and best regards,


More information about the Bioc-devel mailing list