[Bioc-devel] Your branch and 'bioc/master' have diverged

Luca De Sano l.desano at campus.unimib.it
Thu Mar 10 12:22:14 CET 2016

Hi all,
I'm trying to update the devel branch of my package following the
instruction found in https://bioconductor.org/developers/how-to/git-mirrors/

The repo of my project is: https://github.com/BIMIB-DISCo/TRONCO

>From devel I've first tried to do a git merge master, with no results. I've
then tried the cherry-pick method and all seemed to work well. However,
during the git-svn dcommit, I've obtained a:

svn: Commit blocked by pre-commit hook (exit code 1) with output:
The y in the x.y.z version number should be even in release
in file branches/RELEASE_3_2/madman/Rpacks/VegaMC/DESCRIPTION.
See http://bioconductor.org/developers/how-to/version-numbering/

There has been a problem with a commit (a wrong version update which was
rejected from svn).

I've fixed this problem on my master removing the wrong commit as described
here http://www.clock.co.uk/blog/deleting-a-git-commit . I've then tried to
bring those changes on devel doing this:

   - git reset --hard on devel to the last right commit
   - git cherry-pick on the others commit from my master branch

After the cherry-pick, on git, all worked well. The resul of git log is:

dex at darthvader ~/project/TRONCO $ git log --graph --decorate
--pretty=oneline --abbrev-commit --all
*   2e27604 (HEAD, origin/master, origin/development, origin/HEAD, master,
development, devel) Merge pull request #47 from BIMIB-DISCo/development
| * 340c809 date update
* 4700191 dependencies update
* 31c2cab regex problems

I've then tried to commit to svn, but the git svn dcommit --add-author-from
now isn't workig...

dex at darthvader ~/project/TRONCO $ git svn dcommit --add-author-from
Unable to determine upstream SVN information from HEAD history.
Perhaps the repository is empty. at /usr/lib/git-core/git-svn line 856.

And the result of a git status is:

dex at darthvader ~/project/TRONCO $ git status
On branch devel
Your branch and 'bioc/master' have diverged,
and have 615 and 25 different commits each, respectively.
  (use "git pull" to merge the remote branch into yours)

nothing to commit, working directory clean

The situation at the moment is:

   - https://hedgehog.fhcrc.org/bioconductor/trunk/madman/Rpacks/TRONCO/R/
   is a mix of old and new version... I don't know why. Some files are up to
   date with my master and some others no.

   - My master ( https://github.com/BIMIB-DISCo/TRONCO/tree/master ) is up
   to date and I want to bring this on devel

Any idea how to fix this?
Many thanks!

Luca De Sano
Research Associate

Department of Informatics, Systems and Communication
University of Milan Bicocca

Institute of Biomembranes and Bioenergetics of the Italian National
Research Council (IBBE-CNR)

email: l.desano at campus.unimib.it
PEC: luca.desano at pec.it

	[[alternative HTML version deleted]]

More information about the Bioc-devel mailing list