[Bioc-devel] BiocInstaller

Kasper Daniel Hansen kasperdanielhansen at gmail.com
Sun Oct 7 03:34:58 CEST 2012

For an (older) version of R-devel, with BiocInstaller 1.5.12, I did
the following

I updated R-devel, to be current as of today.

I ran biocLite("BiocUpgrade") which updated BiocInstaller to 1.8.1.
Since 1.8.1 is what (as I understand it) identifies Bioc 2.11, I ran
useDevel(TRUE), which banged out with an error (see below).


sleipner:~/> R-devel

R Under development (unstable) (2012-10-06 r60887) -- "Unsuffered Consequences"
Copyright (C) 2012 The R Foundation for Statistical Computing
ISBN 3-900051-07-0
Platform: x86_64-apple-darwin12.2.0 (64-bit)

R is free software and comes with ABSOLUTELY NO WARRANTY.
You are welcome to redistribute it under certain conditions.
Type 'license()' or 'licence()' for distribution details.

  Natural language support but running in an English locale

R is a collaborative project with many contributors.
Type 'contributors()' for more information and
'citation()' on how to cite R or R packages in publications.

Type 'demo()' for some demos, 'help()' for on-line help, or
'help.start()' for an HTML browser interface to help.
Type 'q()' to quit R.

> library(BiocInstaller)
BiocInstaller version 1.8.1, ?biocLite for help
> useDevel(TRUE)
Error: 'devel' version requires a more recent R

More information about the Bioc-devel mailing list