[Bioc-devel] Installing Geoquery on R version 2.13.1

Radhika Malik radhika1990 at gmail.com
Tue Nov 29 05:42:20 CET 2011

Hi Steve,

Thanks for your reply. I'm trying to follow your instructions. First I
was getting the error that it cannot find RCurl. I downloaded the
binary for Rcurl and installed using--

I installed RCurl using R CMD INSTALL /Users/Radhika/Desktop/RCurl_1.7-0.tgz

but now am getting this error--

Error in dyn.load(file, DLLpath = DLLpath, ...) :
  unable to load shared object
6): Library not loaded:
  Referenced from:
  Reason: image not found
Error: package/namespace load failed for 'GEOquery'

What am I missing?


On Mon, Nov 28, 2011 at 11:17 PM, Steve Lianoglou
<mailinglist.honeypot at gmail.com> wrote:
> Hi,
> As shown here:
> http://www.bioconductor.org/install/
> The easiest way to install bioconductor packages is via `biocLite`. Just:
> R> source("http://bioconductor.org/biocLite.R")
> R> biocLite('GEOquery')
> This will install the appropriate version of the bioconductor packages
> for your version of R.
> Also, if you're not "stuck" on R-2.13.x for any particular reason, you
> might as well update to the latest/greatest, which is R-2.14.0, then
> do the biocLite dance.
> -steve
> On Mon, Nov 28, 2011 at 11:05 PM, Radhika Malik <radhika1990 at gmail.com> wrote:
>> Hi,
>> I'm a new developer and am trying to install geoquery on R version
>> 2.13.1 on Mac OS X 10.6.8. I got the binary GEOquery_1.7.2.tgz but am
>> unable to install it
>> 1. I have tried R CMD INSTALL /Users/RM/Desktop/GEOquery_1.7.2.tgz
>> When I do library('GEOquery'), this gives me the error Error: package
>> 'GEOquery' was built before R 2.10.0: please re-install it
>> 2. I tried re-installing by running remove.packages('GEOquery')
>> followed by install.packages('GEOquery') but this gives me the warning
>> Warning message:
>> In getDependencies(pkgs, dependencies, available, lib) :
>>  package ‘GEOquery’ is not available (for R version 2.13.1)
>> and then when I try to do library('GEOquery') it again says Error:
>> package 'GEOquery' was built before R 2.10.0: please re-install it
>> How can I load the library? Any help would be greatly appreciated;
>> I've been trying to just install this for several hours now..
>> Thanks,
>> Radhika
>> _______________________________________________
>> Bioc-devel at r-project.org mailing list
>> https://stat.ethz.ch/mailman/listinfo/bioc-devel
> --
> Steve Lianoglou
> Graduate Student: Computational Systems Biology
>  | Memorial Sloan-Kettering Cancer Center
>  | Weill Medical College of Cornell University
> Contact Info: http://cbio.mskcc.org/~lianos/contact

More information about the Bioc-devel mailing list