[Bioc-devel] GSVA/configure.ac problem

Robert Castelo robert.castelo at upf.edu
Mon Nov 7 19:30:20 CET 2011

dear core developers at BioC,

as you might have seen in a message at BioC, the package GSVA (which i
collaborate maintaining it) requires GSL version >= 1.6, however current
GSL version is 1.15 (see http://www.gnu.org/s/gsl) and in fact the
original version of the package we submitted required version >= 1.12

according to the svn log, the core development of BioC decided to
replace the configure.ac file by other one more appropriate for building
the package in windows and apple machines, so i guess that this 1.6
version requirement change might have been introduced at that point.

i must confess i'm not an expert with configure scripts, so i'd like to
double check with you whether i could solve this issue by simple
replacing all the 1.6 values by 1.12 values. i currently cannot verify
whether that works because in fact the configure script seems to by pass
that requirement, but the message pops up when GSL is not available and
confuses the user about what GSL should be installed in the system.

additionally, our former configure script had the options


in order to allow the user to have a non-system-wide installation of
GSL. i understand that this should be now handled differently to ensure
across-platform compatibility and it depends whether the gsl-config
script is on the PATH variable. would it be possible to add some option
to the configure script to tell where exactly the gsl-config script is??
(in case the user cannot or does not want to have a system-wide
installation of GSL).


More information about the Bioc-devel mailing list