[Bioc-devel] Bioconductor using 64-bit R build

Fraser Sim fjsim at buffalo.edu
Tue Jan 5 23:44:30 CET 2010

Dear all,

I realize this is completely unsupported but wanted to give it a try. I
downloaded the compiled version of Windows 64-bit R that Gong Yu recently
posted details on in the [Rd] mailing list. It starts fine on my version of
Vista. I was able to run the demo(graphics) so I thought I'd try
Bioconductor. Here is the sessionInfo().

> sessionInfo()
R version 2.11.0 Under development (unstable) (2006-00-00 r00000) 

[1] LC_COLLATE=English_United States.1252 
[2] LC_CTYPE=English_United States.1252   
[3] LC_MONETARY=English_United States.1252
[4] LC_NUMERIC=C                          
[5] LC_TIME=English_United States.1252    

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

other attached packages:
[1] limma_3.3.5   Biobase_2.7.3

loaded via a namespace (and not attached):
[1] tools_2.11.0

I tried installing Bioconductor from source using biocLite("Biobase", type =
'source'). This worked when I used the 64-bit MINGW mentioned by Gong. I am
able to load the Biobase library.

I then tried to compile limma which also worked fine. See the sessionInfo
for confirmation. Unfortunately, when I tried to compile genefilter, it
failed when compiling the RSQLite package.

Here is the output.

> biocLite("RSQLite", type = 'source')
Using R version 2.11.0 (R-devel), biocinstall version 2.6.4.
Installing Bioconductor version 2.6 packages:
[1] "RSQLite"
Please wait...

trying URL 'http://cran.fhcrc.org/src/contrib/RSQLite_0.8-0.tar.gz'
Content type 'application/x-gzip' length 1179466 bytes (1.1 Mb)
opened URL
downloaded 1.1 Mb

* installing *source* package 'RSQLite' ...

   WARNING: this package has a configure script
         It probably needs manual configuration

** libs
  making DLL ...
gcc -I"C:/Users/fjsim/DOWNLO~1/R-64BI~1/include"
-DRSQLITE_USE_BUNDLED_SQLITE       -O3 -Wall  -std=gnu99 -c RS-DBI.c -o
In file included from RS-DBI.c:19:0:
RS-DBI.h:45:7: error: conflicting types for 'getpid'
pc-mingw32/include/process.h:150:15: note: previous declaration of 'getpid'
was here
make: *** [RS-DBI.o] Error 1
  ... done
ERROR: compilation failed for package 'RSQLite'
* removing 'C:/Users/fjsim/Downloads/R-64Bit-for-Win64/library/RSQLite'

The downloaded packages are in
Warning message:
In install.packages(pkgs = pkgs, repos = repos, ...) :
  installation of package 'RSQLite' had non-zero exit status

Any ideas what I should try next to get RSQLite? It would be great to have
R/Bioconductor working on 64-bit Windows and I'm willing to help out.


More information about the Bioc-devel mailing list