[Bioc-devel] Creating a package, Error in match.arg(units)

Martin Morgan mtmorgan at fhcrc.org
Tue Aug 25 17:54:06 CEST 2009

Sébastien Laigre wrote:
> Hello everybody,
> I have got several S4 classes for my R application, and I'm trying to create
> a package to deal it easier. It runs on windows XP.
> So I make :
>    - a package.build(........) to build the skeleton of the package.
>    - Rcmd check c:/base/MyApp
> But, checking whether package 'MyApp' can be installed, I have the following
> error (in the install.out file) :
> Error in match.arg(units) :
>   'arg' should be one of "secs", "mins", "hours", "days"
> I already encountered this kind error, and adding "importFrom("package",
> "function") " in the NAMESPACE file solved it.
> But the match.arg function is in the base package and I can not do that.
> Can anyone help me please ? Does anybody knows what can it be due to ?

Have you tried to start a new R session

   R --vanilla

and then source each of the files in the 'R' directory of the package, 
along the lines of

   fls = list.files("c:/base/MyApp/R", full=TRUE)
   for (f in fls) { cat(f, "\n"); source(f) }

? Or can you provide more information about where during the 
installation the error message is generated? Please also include 


> Thank you in advance.
> Sebastien
> 	[[alternative HTML version deleted]]
> _______________________________________________
> Bioc-devel at stat.math.ethz.ch mailing list
> https://stat.ethz.ch/mailman/listinfo/bioc-devel

Martin Morgan
Computational Biology / Fred Hutchinson Cancer Research Center
1100 Fairview Ave. N.
PO Box 19024 Seattle, WA 98109

Location: Arnold Building M1 B861
Phone: (206) 667-2793

More information about the Bioc-devel mailing list