[Bioc-devel] assayDat and ExpressionSet

Vincent Carey 525-2265 stvjc at channing.harvard.edu
Thu Oct 18 22:49:26 CEST 2007

> Vincent Carey 525-2265 wrote:
> > i think the phenoData class should be defunct at next release,
> > but the slots should retain their names.
> I think "featureData" and "sampleData" would be more consistent as the
> prefered accessor functions to the annotatedDataframes for annotating
> 'rows' and 'colums' of an eSet, respectively.
> I don't care too much how the slot in the class implementation is
> called, but if our software is what we claim it is, we might as well
> also be able to rename the eSet slot "phenoData" to "sampleData", and
> keep accessor functions named phenoData and phenoData<- (that do the
> same as sampleData...) still around for a couple of releases.
> This is a long-term question of low urgency, but I do find it important
> for the user experience that we call things by their proper names and
> not use inexact and potentially confusing terminology (or doesn't it
> make you whince when your biological collaborators talk of "p-values"
> when they mean regression coefficients?)

"phenoData" has reasonable associations among the users/students i've encountered.
so the need for an alternate name for the accessor is not completely
clear.  but i would have no strong objection to these changes once
resources to carry them out were identified.

The information transmitted in this electronic communica...{{dropped:2}}

More information about the Bioc-devel mailing list