[Bioc-devel] Error loading, on Bioconductor 1.8, exprSet generated with bioconductor 1.7

rcaloger raffaele.calogero at unito.it
Wed Jun 7 15:49:46 CEST 2006

today I was working on an Affy exprSet I saved before the new release of 
Bioconductor (1.8).
I loaded it but I got the following error when I tried to show it:
Error in slot(object, what) : no slot of name "pubMedIds" for this 
object of class "MIAME"

Furthermore, if I issue the command:
I got this error:
Error in FUN(X[[6]], ...) : no slot of name "reporterInfo" for this 
object of class "exprSet"

The error comes using the  Biobase Version: 1.10.0. Everythink run 
smootly if I run the same commands on Bioconductor 1.7 installed under 

I was expecting that there should be some sort of back compatibility 
with  at least the previous release of the exprSet. There is any way to 
convert old instances of exprSet in the new one?


Prof. Raffaele A. Calogero
Bioinformatics and Genomics Unit
Dipartimento di Scienze Cliniche e Biologiche
c/o Az. Ospedaliera S. Luigi
Regione Gonzole 10, Orbassano
10043 Torino
tel.   ++39 0116705420
Lab.   ++39 0116705408
Fax    ++39 0119038639
Mobile ++39 3333827080
email: raffaele.calogero at unito.it
www:   www.bioinformatica.unito.it

More information about the Bioc-devel mailing list