rosv: Client to Access and Operate on the 'Open Source Vulnerability' API

Connect, query, and operate on information available from the 'Open Source Vulnerability' database <https://osv.dev/>. Although 'CRAN' has vulnerabilities listed, these are few compared to projects such as 'PyPI'. With tighter integration between 'R' and 'Python', having an 'R' specific package to access details about vulnerabilities from various sources is a worthwhile enterprise.

Version: 0.5.1
Depends: R (≥ 2.10)
Imports: digest (≥ 0.6.0), furrr (≥ 0.3.0), httr2 (≥ 1.0.0), jsonlite (≥ 0.9.16), memoise (≥ 2.0.0), purrr (≥ 1.0.0), R6 (≥ 2.0.0), utils
Suggests: httptest2 (≥ 1.0.0), knitr, rmarkdown, testthat (≥ 3.0.0)
Published: 2023-12-04
Author: Allen OBrien [aut, cre, cph]
Maintainer: Allen OBrien <allen.g.obrien at gmail.com>
BugReports: https://github.com/al-obrien/rosv/issues
License: MIT + file LICENSE
URL: https://al-obrien.github.io/rosv/, https://github.com/al-obrien/rosv
NeedsCompilation: no
Materials: README NEWS
CRAN checks: rosv results

Documentation:

Reference manual: rosv.pdf
Vignettes: Introduction to rosv

Downloads:

Package source: rosv_0.5.1.tar.gz
Windows binaries: r-prerel: rosv_0.5.1.zip, r-release: rosv_0.5.1.zip, r-oldrel: rosv_0.5.1.zip
macOS binaries: r-prerel (arm64): rosv_0.5.1.tgz, r-release (arm64): rosv_0.5.1.tgz, r-oldrel (arm64): rosv_0.5.1.tgz, r-prerel (x86_64): rosv_0.5.1.tgz, r-release (x86_64): rosv_0.5.1.tgz
Old sources: rosv archive

Linking:

Please use the canonical form https://CRAN.R-project.org/package=rosv to link to this page.